FC2ブログ

linuxやるブログ

linuxができなくて悔しい思いしてるので、linuxやるぞ~ 初歩的なやつから少しずつ。 OSはCentOS5.3がメインだす。正確性は保障できませぬ。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PageTop

rpm

① rpm -qf あるファイルがどのパッケージに入ってたかを調べるオプション

例: /usr/bin/mkpasswd がどこのパッケージに入っていたかを確認する

# rpm -qf /usr/bin/mkpasswd
expect-5.43.0-5.1  ← expectに入っていたのね。


②rpm -ql あるパッケージはどんなファイルを含んでいるか調べるオプション 

# rpm -ql expect-5.43.0-5.1
/usr/bin/autoexpect
/usr/bin/dislocate
/usr/bin/expect
/usr/bin/ftp-rfc
/usr/bin/kibitz
/usr/bin/lpunlock
/usr/bin/mkpasswd
/usr/bin/passmass
/usr/bin/rftp
/usr/bin/rlogin-cwd
/usr/bin/timed-read
/usr/bin/timed-run
/usr/bin/unbuffer
/usr/bin/weather
/usr/bin/xkibitz
/usr/lib/expect5.43
/usr/lib/expect5.43/cat-buffers
/usr/lib/expect5.43/pkgIndex.tcl
/usr/lib/libexpect5.43.so
   ・
   ・
   ・
これらのファイルを含んでいるんです

③rpm --test インストール前のテスト
  
# rpm --test -ivh php-5.1.6-1.i386.rpm
error: Failed dependencies:
php-cli = 5.1.6-1 is needed by php-5.1.6-1.i386.rpm
php-common = 5.1.6-1 is needed by php-5.1.6-1.i386.rpm

④rpm --nodeps 依存性無視してインストール

# rpm --nodeps -ivh php-5.1.6-1.i386.rpm
Preparing... ########################################### [100%]

PageTop

コメント


管理者にだけ表示を許可する
 

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。